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SPECBUILDER : 1. LOGGING IN 

1 SPECBUILDER: LOGGING IN 

 

 
Figure 1a: The SPECbuilder login screen 

 

1.1 To Log In 

1. Access SPECbuilder via the link on the NATSPEC homepage (www.natspec.com.au). 
2. Email address: Enter the email address that you supplied on your subscription order form. 
3. Password: Enter the password emailed from NATSPEC. If you haven’t received an email from NATSPEC 

with your password information, click on I forgot my password, and a new password will be emailed to you. 
4. Click on the I agree to abide by the Subscription Conditions checkbox. Click Login to enter the site and 

view the SPECbuilder Home page (Figure 1b). 
 

 
Figure 1b: SPECbuilder Homepage 

 
Your subscriptions: NATSPEC packages subscribed to by your organisation. 
You can return to the SPECbuilder Homepage at any time by clicking on the Home tab on the upper toolbar. 

http://www.natspec.com.au/
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SPECBUILDER : 2. CREATING A PROJECT DRAFT 

2 CREATING A PROJECT DRAFT 

 

 
Figure 2a: Create Project page 

 
Steps for creating a project: 
1. Click on Create Project on the SPECbuilder Homepage. This opens the Create Project page (Figure 2a). 

2. The Print button creates a printable checklist of all available Worksections to assist with selecting which 
Worksections will be used in a project. 

3. Select the worksections required for the specification. Click on the Word icon to download and view the contents 
of the worksection. 
Worksections in blue are NATSPEC. Worksections in red are AUS-SPEC. 

4. Check your selections in the Selected worksections box on the right hand side. Click on the Create button and 
you will see the Create new Project Specification popup (Figure 2b). 

5. Fill in the Title for the Project. Description and Metadata (more information if necessary) are optional. Click 
Create. 

 

 



NATSPEC Paper  
 

 

5 of 20 

SPECBUILDER : 2. CREATING A PROJECT DRAFT 

Figure 2b: Create new Project Specification 
 
 

 
Figure 2c: Project Specification page 

 
The Project page appears (Figure 2c). This page contains information about the project created. This page lists the 
worksections selected for the project. 
 

1. Click Download to download the project to your computer or server. 

2. The downloaded zip file needs to be extracted/expanded/unzipped into a folder. 

3. Start editing your project. 

 

Figure 2e: Download save dialog 
 

SPECbuilder uses your browser download functions to download the zip file. Some browsers automatically download 
files from the internet to a Downloads folder on your computer, other browsers ask you where you want to save the 
file. 
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SPECBUILDER : 3. ADDING AND DELETING A WORKSECTION 

3 ADDING AND DELETING A WORKSECTION 

Steps to add a worksection to an existing project. 
1. Click on View Projects 
2. Choose the Project to Add or Delete worksections from 
3. Click the Edit button – this will take you back to the Selection tree. 

 

 
Figure 3b: Project Specification page 

 
 

 
Figure 3c: Editing the Project Contents 

 
 

Make the edits required using the same method used when creating the project. 
Click on the Download Project button to download the amended project. 
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SPECBUILDER : 3. ADDING AND DELETING A WORKSECTION 
 

WARNING!! PLEASE NOTE: The zip file that will be created and downloaded contains ALL the files for 

the project. You may have already edited some of the project files. Make sure the unzip program you are 
using does not automatically overwrite existing files or you will lose existing work. 
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SPECBUILDER : 4. UPLOADING AN OFFICE EDITED WORKSECTION 

4 UPLOADING AN OFFICE EDITED WORKSECTION 

It is possible to include your own Office Edited Worksections in the SPECbuilder system. These files are uploaded 
and linked to the NATSPEC Classification system and are then available for users when creating a new project 
specification. 
 
Note that files uploaded to SPECbuilder must be in the .docx format. 
 
To upload your own Office Edited Files, click on Upload Office Edited File on the Homepage. You will see the 
Upload User’s Document page. 
 

 
 

 
Figure 4a: Upload User’s Document page 

 
1. Click on Choose File button 
2. Navigate to where the Office Edited File is located 
3. Select the file and click Open 
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SPECBUILDER : 4. UPLOADING AN OFFICE EDITED WORKSECTION 
 

4. Type in a title e.g. 0331 HS Brick and block construction. Please make sure it is different from the NATSPEC file 
title – to identify that it is different. 

5. For Classification number please insert the appropriate 4-digit classification number – this is so the uploaded 
worksection appears in the correct location in the file tree. 

 

 
Figure 4b: Worksection classification tree 

 
Once your files have been uploaded they will be available in the classification tree for selection. The Office Edited 
Files are in green. 
 
RECOMMENDATION: It is recommended that you use this feature minimally. Each Office edited worksection that is 
created will need to be updated manually as NATSPEC does not automatically make changes to your files. 
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MS WORD: 6D. MERGE METHOD # 2 – FOR WORD 2007, 2010 & 2013 ONLY 

5 WHAT IS A MASTER DOCUMENT? 

SPECbuilder creates what is called a Master Document from the worksections selected for your project. 
 
A Master Document is a feature found in Microsoft Word. It is basically a standard Word document with links to other 
Word documents. 
 

 
Figure 5a: A Microsoft Word Master Document – as created by SPECbuilder 

 
 
The following instructions guide you through expanding these links. The final document will look like a fully merged 
file. The master document and each of the subdocuments are linked – any changes you make to either will appear in 
both. Once the document is fully expanded you can go back to Page Layout view and update the Table of Contents 
or make any global changes that are required. 
 
RECOMMENDATION: It is recommended that the bulk of the editing required be done in each of the individual 
worksection files rather than the Master Document. There will be far less problems with Microsoft Word if you use the 
Master Document only for generating/updating the Table of Contents, searching for prompts and any global changes 
that may need to be made. 
 
For more information look at the Microsoft Word Help section on Master Documents. 
 

6 USING A MASTER DOCUMENT 

6.1 For Microsoft Word 2007 and later 

Open the merged document. The document will have hyperlinks to all the subdocuments (worksections). 
 

4. To expand the document, go to View Ribbon and click Outline. 

 
View Ribbon 

 
5. On the Outlining Ribbon click the Expand subdocuments button to see the document in full. 

 
Outlining Ribbon 
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SPECBUILDER : 4. UPLOADING AN OFFICE EDITED WORKSECTION 
 

6.2 Merging – Method 2 (Windows only) 

Another way to merge your document is within Word itself. In the later versions of Word you have the 
Insert/Object/Text from file option. 
 
1. Open a blank document 
2. Select the Insert Tab 
3. Click the arrow on the Object button and select Text from file 
4. Navigate to your Project folder 
5. Type Ctrl A (Select All) 
6. Keeping the Ctrl key pressed, unselect any files that you DO NOT want in the merged document. 
7. Press Insert. 
8. Save the file 
 
Please note you will have to manually insert Page Breaks (Ctrl Enter) if you wish. 
 
This method “pastes” the text into a new document – this document is not linked in any way to the subdocuments. 
 

 
 
This method also works for Macintosh Users, except that Step 5 is not applicable – you cannot select all the files in 
the project folder in one go. You need to select each file to be inserted one at a time. Still a reasonably quick and 
easy way to merge multiple documents. 
 
 



NATSPEC Paper  
 

12 of 20 

MS WORD: 6B. USING MASTER DOCUMENTS 

1. Attach the natspec.dot template, to have NATSPEC formatting and Toolbar available. Go to Developer tab 
and select Document Template. 

 
Developer Ribbon 

 
2. Click on the Attach button and choose natspec.dot, click Open, check the Automatically update document 

styles checkbox and click OK. 

 
Templates and Add-ins dialog 

 
If you cannot see the Developer Tab … 
 
To work with Templates you will need access to the Developer Tab, which is not available unless you turn it on. To 
view the Developer tab: 
1. Select the File tab. 
2. Select Options. 
3. On the Word Options dialogue box select Customize Ribbon on the Left Menu and then Tick the checkbox next to 
Developer. 
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MS WORD: 6B. USING MASTER DOCUMENTS 
 

    
 
You will now see the Developer Tab on the main screen 
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MS WORD: 6C. USING MASTER DOCUMENTS (MACINTOSH) 
 

6.3 For Microsoft 2008 (Macintosh) 

1. Click on the Tools menu 
2. Choose Templates and Add-ins 
3. Click on Attach 
4. Navigate to the location where natspec.dot is saved 
5. Click on Automatically update document styles 
6. Click on OK 
 

              
 

1. To expand the document, go to View/Outline. You will see the Outlining Toolbar. The last button on the 
Toolbar is as shown below 

 

 

 

2. On the Master Documents toolbar click the Expand subdocuments button to see the document in full. 

 
 
 

 

6.4 Where to save the natspec.dotm file 

6.4.1 Windows 7 and 10 

1. Copy natspec.dot 
2. Navigate to C:\Users\Your Log in\AppData\Roaming\Microsoft\Templates 
3. Paste the file 
 
6.4.2 Macintosh 

1. Copy natspec.dot 
2. Navigate to Yourlogin\Library\Application support\Microsoft\Office\User Templates\My Templates 
3. Paste the file 
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SPECBUILDER :8. ADDING MORE MEMBERS 

7 RESOURCE MATERIAL 

 
Figure 7a: SPECbuilder Homepage 

 
Click on the Resource material link on the SPECbuilder Homepage. 
 

 
Figure 7b: Resource Material Downloads page 

 
The Resource Material Downloads page links to the PDF documents that are part of your subscription. Documents 
available for download include TECHnotes, TECHreports, NATsource, etc. This is material that is available to all 
subscribers. 
 
Subscription downloads 
If you wish to download your entire package so that it is local rather than online do the following: 

• Login to SPECbuilder  

• Click on the SPECbuilder link to the right of the Homepage. 

• Click on Subscription downloads (far right). 

• Click on Package zip files to open the folder and select the file to download it to your computer (using your Browser 
download function) 
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MS WORD: 6B. USING MASTER DOCUMENTS 
 

• Once the file is downloaded, unzip/extract the file and copy it to wherever you wish to keep the files for access. 

 

 
 
The Worksections folder contains PDF files of the package you have subscribed to in Workgroups. It is fully 
searchable and printable. These documents contain the changes since the previous update highlighted in yellow. 
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MS WORD: 6B. USING MASTER DOCUMENTS 
 

7.1 Adding more members 

The nominated office contact in the NATSPEC database is considered the Manager (Administrator). The Manager is 
able to add more users/members from their organisation. 
NOTE: Under NATSPEC Subscription Conditions each Office must have its own subscription. Each subscribing 
Office may have as many members as required. 
 

7.2 To add another Member 

1. Login to SPECbuilder . 
2. Click the Admin tab and click on Manage users 

 

 
 
 

3. Enter the relevant information. 
4. Under Member Options choose whether the new member will be a Manager or Contributor. 
5. Click Save. The new member will be emailed their login information 

 
 

Figure 8a: Add new member page 
 

7.3 Deleting Members 

1. Login to SPECbuilder  
2. Click the Members tab and click on List 
3. Locate the Member to be deleted and click on the blue cross under the Action column. 
4. Click Remove on the popup box. 
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MS WORD: 6B. USING MASTER DOCUMENTS 
 

 
Figure 8b: Member List page 
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SPECBUILDER : 9. CHANGE YOUR PASSWORD 

8 CHANGE YOUR PASSWORD 

1. Login to SPECbuilder . 
2. Click the menu under your name and select on My Details 
3. Enter the relevant information. 
4. Click Save changes. 

 

 
Figure 9a: Change Personal Details page 
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THE LAST WORD 

9 THE LAST WORD 

9.1 Microsoft Word versions 

The documents created in SPECbuilder are in Microsoft Word DocX format. If you are running an earlier version 
(*.doc) of Microsoft Word you can still use these files though you will need to download the Compatibility Pack in 
order to read these files. 
 

9.2 A word on Browsers 

The best browsers to use – if you have a choice – are Firefox and Chrome. Sometimes if things are not working as 
they should – try a different browser to see if you can duplicate the issue. 
 

9.3 Other wordprocessing applications 

We have some users who are using other wordprocessing programs such as Pages on the Macintosh and Google 
Docs. There is no reason why you can’t use these programs but there will be issues with the Guidance (hidden) text 
and other more advanced features. 
 
If you wish to continue using these applications the Guidance text is available for you to read in the supplied PDF 
files. 
 

9.4 Changes and Feedback 

SPECbuilder is an evolving program. We take Subscriber Feedback very seriously and have made some changes to 
the user interface to address this feedback. Any comments would be appreciated. Please note that there will be 
changes from time to time but that we do try to keep them to a minimum. 
 


